Using Cascading Style Sheets styles

By default, Dreamweaver uses Cascading Style Sheets (CSS) styles to format text. The styles that you apply to text using the Property inspector or menu commands create CSS rules which are embedded in the head of the current document. CSS styles provide you with greater flexibility and control over the appearance of your page, from the precise positioning of layout to specific fonts and text styles. 

In addition to styles and style sheets you create, you can use style sheets that come with Dreamweaver to apply styles to your documents. (See Creating a document based on a Dreamweaver design file.)
About formatting text

Formatting text in Dreamweaver is similar to using a standard word processor. You can set default formatting styles (Paragraph, Heading 1, Heading 2, and so on) for a block of text, change the font, size, color, and alignment of selected text, or apply text styles such as bold, italic, code (monospace), and underline.

By default, Dreamweaver formats text using Cascading Style Sheets (CSS) styles. CSS styles give web designers and developers greater control over web page design, while providing improved features for accessibility and reduced file size. As you style and align text using Dreamweaver formatting commands, CSS rules are embedded in the current document. This lets you more easily re-use existing styles that you create, as well as allowing you to name the styles you use. CSS is becoming the preferred method by which to format text and lay out web pages. 

If you prefer, you can use HTML markup tags to format and align text in your web pages. If you need to use HTML tags instead of CSS styles, you must change the Dreamweaver default text formatting preferences. (For more information, see Specifying HTML instead of CSS.)

Using CSS styles is a way to control the style of a web page without compromising its structure. By separating visual design elements (fonts, colors, margins, and so on) from the structural logic of a web page, CSS style sheets give web designers both visual and typographic control without sacrificing the integrity of the content. In addition, defining typographic design and page layout from within a single, distinct block of code--without having to resort to image maps, <font> tags, tables, and spacer GIFs--allows for faster downloads, streamlined site maintenance, and a central point from which to control design attributes across multiple web pages. 

CSS styles define the formatting for all text in a particular class or redefine the formatting for a particular HTML tag (such as h1, h2, p, or li).

You can store CSS styles directly in the document or, for more power and flexibility, in an external style sheet. If you attach an external style sheet to several web pages, all the pages automatically reflect any changes you make to the style sheet. To access CSS styles, use the CSS Styles panel or the Style pop-up menu of the text Property inspector. For more information about using the text Property inspector to apply HTML or CSS styles, see Setting text property options.

Note: You can combine CSS styles and HTML 3.2 formatting within the same page. Formatting is applied in a hierarchical manner: HTML 3.2 formatting overrides formatting applied by external CSS style sheets, and CSS styles embedded in a document override external CSS styles. See Using Cascading Style Sheets styles.

Understanding Cascading Style Sheets

Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of content in a web page. With CSS styles you have great flexibility and control of the exact page appearance, from precise positioning of layout to specific fonts and styles.

CSS styles let you control many properties that cannot be controlled using HTML alone. For example, you can assign custom list bullets and specify different font sizes and units (pixels, points, and so on). By using CSS styles and setting font sizes in pixels, you can ensure a more consistent treatment of your page layout and appearance in multiple browsers. In addition to text formatting, you can control the format and positioning of a block-level elements in a web page. For example, you can set margins, borders, float text around other text, and so on.

A CSS style rule consists of two parts--the selector and the declaration. The selector is the name of the style (such as TR, or P) and the declaration defines what the style elements are. The declaration consists of two parts, the property (such as font-family), and value (such as Helvetica). The term cascading refers to your ability to apply multiple style sheets to the same web page. For example, you can create one style sheet to apply color and another to apply margins, and apply them both to the same page to create the design you want.

A major advantage of CSS styles is that they provide easy update capability; when you update a CSS style, the formatting of all the documents that use that style are automatically updated to the new style.

You can define the following types of CSS styles in Dreamweaver:

· Custom CSS styles, also called class styles, let you set style attributes to any range or block of text (see Applying a Class style). 

· HTML tag styles redefine the formatting for a particular tag, such as h1. When you create or change a CSS style for the h1 tag, all text formatted with the h1 tag is immediately updated. 

· CSS selector styles redefine the formatting for a particular combination of tags (for example, td h2 applies whenever an h2 header appears inside a table cell) or for all tags that contain a specific id attribute (for example, #myStyle applies to all tags that contain the attribute-value pair id="myStyle"). 

CSS tags can reside in the following locations:

External CSS style sheets are collections of CSS styles stored in a separate, external file .css file (not an HTML file). This file is linked to a one or more page pages in a website using a link in the head section of a document. 

Internal (or Embedded) CSS style sheets are collections of CSS styles included in a style tag in the head portion of an HTML document. 

Inline styles are defined with specific instances of tags throughout an HTML document.

CSS styles can define the formatting attributes for HTML tags, ranges of text identified by a class attribute. Dreamweaver MX recognizes styles defined in existing documents as long as they conform to CSS style guidelines.

Tip: To display the O’Reilly CSS reference guide included with Dreamweaver, select Help > Reference and select O’Reilly CSS Reference from the pop-up menu in the Reference panel.

Manual HTML formatting overrides formatting applied with CSS styles. For CSS styles to control the formatting of a paragraph, you must remove all manual HTML formatting.

Most styles attributes you apply can be viewed in the Document window. You can also preview the document in a browser window to see it applied. Some of the CSS style attributes are rendered differently in Microsoft Internet Explorer, Netscape Navigator, Opera, and Apple Safari, and some are not currently supported by any browser.

Using the CSS Styles panel 

You use the CSS Styles panel to create, edit, and remove CSS styles, as well as to attach external style sheets to documents. 

To open the CSS Styles panel:

· Do one of the following: 

· Select Window > CSS Styles. 

· Press Shift+F11. 

The CSS Styles panel lets you look at the style definition of the styles associated with the current document, as well as the hierarchy of the styles. The CSS Styles panel displays style definitions of custom (class) CSS styles, redefined HTML tags, and CSS selector styles. 

When you create or attach a CSS style sheet, the style’s name and attributes appear in the CSS Styles panel. The CSS Styles panel lists all the selectors defined in all style tags and externally linked or imported style sheets. When you create a custom (class) style, it appears in the CSS Styles panel, the Style pop-up menu in the Property inspector, and in the Text > CSS Styles submenu. 

The following buttons are located at the bottom of the CSS Styles panel:



Attach Style Sheet opens the Link External Style Sheet dialog box. Select an external style sheet to link to or import into your current document. For information about attaching an external style sheet, see Exporting styles to create a CSS style sheet.

New CSS Style opens the New CSS Style dialog box. You use the New CSS Styles dialog to select the type of style you’re creating--for example, to create a class style, redefine an HTML tag, or to define a CSS selector. For information about creating a new style, see Creating a new CSS style.

Edit Style Sheet opens the CSS Style Definition dialog box. Edit any of the styles in the current document or in an external style sheet. For information about updating a style sheet, see Editing a CSS style.

Delete CSS Style removes the selected style from the CSS Styles panel, and removes the formatting from any element to which it was applied. 

Note: Right-click (Windows) or Control-click (Macintosh) the CSS Styles panel to open a context menu of options for working with CSS Style Sheet commands.

Related topics

· Creating a new CSS style 

· Applying a Class style 

· Linking to or importing an external CSS style sheet 

· Editing a CSS style 

· Editing a CSS style sheet 

Using the Relevant CSS tab

Use the Relevant CSS tab to view and modify the properties of selected CSS elements in the current document. The Relevant CSS tab lets you see what rules are affecting the current selection, and what tags those rules relate to.

To open the Relevant CSS tab:

1. Select Window > Tag inspector. 

The Tag inspector appears.

2. Click the Relevant CSS tab to display the properties for the current page. 

3. Select a text element in the current page to display its properties. 

The Relevant CSS tab displays the CSS rules for the current selection, the name and location of the file containing the CSS rules, and the rule’s relevant properties.

To edit a CSS rule using the Relevant CSS tab, do one of the following:

· Double-click the rule in the Relevant CSS tab to both open the rule’s code editing, and to display the CSS Property inspector. 

· Edit the rule’s properties using the controls provided in the lower half of the Relevant CSS tab window. 

Related topics

· The Relevant CSS tab 

· Using the CSS Properties tab 

· Creating a new CSS style 

· Editing a CSS style 

Creating a new CSS style

You can create a CSS style to automate the formatting of HTML tags or a range of text identified by a class attribute.

To create a new CSS style: 

1. Place the insertion point in the document, then do one of the following to open the New CSS Style dialog box: 

· In the CSS Styles panel (Window > CSS Styles), click the New CSS Style button (+) located in the lower right area of the panel. 

· In the text Property inspector, select Manage Styles from the Style pop-up menu, and click New in the dialog box that is displayed. 

· In the Relevant CSS tab (Select Window > Tag inspector, and click the Relevant CSS tab) right-click and select New Rule from the context menu. 

· Select Text > CSS Styles > New CSS Style. 

The New CSS Style dialog box appears. 

2. Define the type of CSS style you want to create: 

· To create a custom style that can be applied as a class attribute to a range or block of text, select Make Custom Style (Class), then in the Name text box, enter a name for the style. 

Note: Class names must begin with a period and can contain any combination of letters and numbers (for example, .myhead1). If you don’t enter a beginning period, Dreamweaver automatically enters it for you.

· To redefine the default formatting of a specific HTML tag, select Redefine Tag, then in the Tag field, enter an HTML tag or select one from the pop-up menu. 

· To define the formatting for a particular combination of tags or for all tags that contain a specific Id attribute, select Use CSS Selector, then in the Selector text box, enter one or more HTML tags or select one from the pop-up menu. The selectors (known as pseudo-class selectors) available from the pop-up menu are a:active, a:hover, a:link, and a:visited. 

3. Select the location in which the style will be defined: 

· To create an external style sheet, select New Style Sheet File. 

· To embed the style in the current document, select This Document Only. 

4. Click OK. 

The Style Definition dialog box appears. 

5. Select the style options you want to set for the new CSS style. 

6. When you are done setting style attributes, click OK. 

For information on specific CSS style settings, see the following topics:

· Defining CSS type properties 

· Defining CSS style background properties 

Defining CSS type properties 

You use the Type category in the CSS Style Definition dialog box to define basic font and type settings for a CSS style. 

See also Using Cascading Style Sheets styles and Editing a CSS style.

To define type settings for a CSS style:

1. Open the CSS Styles panel (Shift + F11), if it isn’t already open. 

2. Open the CSS Style Definition dialog box by doing one of the following: 

· Add a new style. For detailed information, see Creating a new CSS style. 

· Double-click an existing style to open it for editing in Code view or in the CSS Properties tab. 

3. In the CSS Style Definition dialog box, select Type, then set the style attributes you want. 

Leave any of the following attributes empty if they are not important to the style:

Font sets the font family (or series of families) for the style. Browsers display text in the first font in the series that is installed on the user’s system. For compatibility with Internet Explorer 3.0, list a Windows font first. The font attribute is supported by both browsers.

Size defines the size of the text. You can choose a specific size by selecting the number and the unit of measurement, or you can choose a relative size. Pixels as a unit work well to prevent browsers from distorting your text. The size attribute is supported by both browsers.

Style specifies Normal, Italic, or Oblique as the font style. The default setting is Normal. The style attribute is supported by both browsers.

Line Height sets the height of the line on which the text is placed. This setting is traditionally called leading. Select Normal to have the line height for the font size calculated automatically, or enter an exact value and select a unit of measurement.The line height attribute is supported by both browsers. 

Decoration adds an underline, overline, or line-through to the text, or makes the text blink. The default setting for regular text is None. The default setting for links is Underline. When you set the link setting to none, you can remove the underline from links by defining a special class.The decoration attribute is supported by both browsers.

Weight applies a specific or relative amount of boldface to the font. Normal is equivalent to 400; Bold is equivalent to 700. The weight attribute is supported by both browsers.

Variant sets the small caps variant on text. Dreamweaver does not display this attribute in the Document window. The variant attribute is supported by Internet Explorer but not Navigator.

Case capitalizes the first letter of each word in the selection or sets the text to all uppercase or lowercase. The case attribute is supported by both browsers.

Color sets the text color. The color attribute is supported by both browsers.

4. When you are finished setting these option, select another CSS category on the left side of the panel to set additional style attributes, or click OK. 

Defining CSS style background properties

You use the Background category of the CSS Style Definition dialog box to define background settings for a CSS style. You can apply background properties to any element in a web page. For example, create a style which adds a background color or background image to any page element, for example behind text, a table, the page, and so on. You can also set the positioning of a background image. See also Using Cascading Style Sheets styles and Editing a CSS style. 

To define background settings:

1. Open the CSS Styles panel (Shift+F11), if it isn’t already open. 

2. Open the CSS Style Definition dialog box by doing one of the following: 

· Add a new style. For detailed information, see Creating a new CSS style. 

· Double-click an existing style to open it for editing in Code view or in the CSS Properties tab. 

3. In the CSS Style Definition dialog box, select Background, then set the style attributes you want. 

Leave any of the following attributes empty if they are not important to the style: 

Background Color sets the background color for the element. The background color attribute is supported by both browsers.

Background Image sets the background image for the element.The background image attribute is supported by both browsers.

Repeat determines whether and how the background image is repeated. The Repeat attribute is supported by both browsers.

No Repeat displays the image once at the beginning of the element.

Repeat tiles the image horizontally and vertically behind the element.

Repeat-x and Repeat-y display a horizontal and vertical band of images, respectively. Images are clipped to fit within the boundaries of the element.

Note: Use the Repeat property to redefine the body tag and set a background image that does not tile or repeat.

Attachment determines whether the background image is fixed at its original position or scrolls along with the content. Note that some browsers may treat the Fixed option as Scroll. This is supported by Internet Explorer but not Netscape Navigator. 

Horizontal Position and Vertical Position specify the initial position of the background image in relation to the element. This can be used to align a background image to the center of the page, both vertically and horizontally. If the attachment property is Fixed, the position is relative to the Document window, not to the element. This attribute is supported by Internet Explorer but not Netscape Navigator.

4. When you are finished setting these options, select another CSS category on the left side of the panel to set additional style attributes, or click OK. 

Editing a CSS style

You can easily edit both internal and external styles you have applied to a document. 

When you edit a CSS style sheet that controls the text in your document, you instantly reformat all of the text controlled by that CSS style sheet. Edits to an external style sheet affect all the documents linked to it. 

You can set an external editor for editing style sheets. For information about setting up an external editor, see Starting an external editor for media files. 

To edit a CSS style:

1. Select Window > Tag inspector. 

2. In the Tag inspector, click the Relevant CSS tab to view the CSS styles in the current document. 

3. Place the insertion point in the text whose CSS style you want to edit. 

Each CSS style you select in the page displays in the CSS panel.

4. Click the style you want to edit to select it, then do one of the following: 

· Double-click the selected style in the CSS Styles panel. 

· Right-click (Windows) or Control-click (Macintosh), then select Edit Rule from the content menu. 

· Click the Edit Style button located at the bottom of the CSS panel. 

· Select the style in the CSS panel, and edit its properties in the CSS Property inspector. 

The changes you make are immediately applied to the current document, allowing you to preview your changes as they are made. If you are editing styles stored in an external style sheet, be sure to save your changes to see your updates applied.

5. When you are finished editing the style, save your work. 

If you modify CSS styles that are in a styles sheet used by more than one document, those changes will be reflected in those pages as well.

Applying a Class style

Class styles are the only type of CSS style that can be applied to any text in a document, regardless of which tags control the text. All class styles associated with the current document are displayed in the CSS Styles panel (with a period (.) prepended to their name) and in the Style pop-up menu of the text Property inspector.

You’ll see most styles updated immediately, however, you should preview your page in a browser to verify a style was applied as expected. When you apply two or more styles to the same text, the styles may conflict and produce unexpected results. For more information, see About conflicting CSS styles.

Tip: When previewing styles defined in an external CSS style sheet, be sure to save the style sheet to ensure that your changes are reflected when you preview the page in a browser.

To apply a custom CSS style:

1. In the document, select the text to which you want to apply a CSS style. 

Place the insertion point in a paragraph to apply the style to the entire paragraph.

If you select a range of text within a single paragraph, the CSS style affects only the selected range.

To specify the exact tag to which the CSS style should be applied, select the tag in the tag selector located at the bottom left of the Document window. 

2. To apply a class style, do one of the following: 

· In the CSS Styles panel (Window > CSS Styles), right-click the name of the style you want to apply and select Apply from the context menu. 

· In the text Property inspector, select the class style you want to apply from the Style pop-up menu. 

· In the Document window, right-click (Windows) or Control-click (Macintosh) the selected text, and in the context menu, select CSS Styles and then select the style you want to apply. 

· Select Text > CSS Styles, and in the submenu select the style you want to apply. 

To remove a custom style from a selection: 

1. Select the object or text you want to remove the style from. 

2. Do one of the following: 

· In the text Property inspector, select None from the Style pop-up menu. 

· Right-click the applied rule you want to remove in the Relevant CSS tab and select Set Class > None from the context menu. 
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